[RESOLVED] mi3-sr19 :: Service Interruption Saturday 16th July 2022 17:54:28


mi3-sr19.supercp.com is currently experiencing a service interruption. Users hosted on this server may get database errors as a result. Our System Operations team is running the maintenance right now. We will provide updates as more details are made available.

UPDATE 10:07PM EDT: Issues affecting mi3-sr19 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.