[COMPLETED] Michigan Datacenter :: Scheduled Maintenance Wednesday 13th July 2022 20:30:00


Start Date: Wednesday, July 13th, 2022

End Date: Thursday, July 14th, 2022

Time: 11:00 PM - 03:00 AM EDT

Description: Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread

UPDATE 11:20PM EDT: The scheduled maintenance for the Michigan Datacenter has begun. We will provide additional updates as they become available.

UPDATE 12:35AM EDT, July 14th: The maintenance has now been completed.