[RESOLVED] NLLS4 :: Scheduled Maintenance Thursday 10th May 2018 15:08:36


NLLS4 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 19:30 EDT: NLLS4 is back online.