[COMPLETED] Singapore Datacenter :: Scheduled Maintenance Wednesday 29th June 2022 13:37:59


Start Date: Thursday, June 30th, - 12:00 PM EDT (12:00 SGT)

End Date: Thursday, June 30th, - 3:00 PM EDT (15:00 SGT)

Description: Our Network Engineering team is performing network maintenance in our Singapore Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will provide updates as they're made available.

UPDATE: Maintenance has been completed. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.