[COMPLETED] Netherlands Backup Power Scheduled Maintenance Wednesday 29th June 2022 11:00:00


Start Date: Tuesday, June 29, 2022

End Date: Wednesday, June 30, 2022

Time: 8:00 PM - 05:00 AM GMT (3:00 PM - 00:00 EDT)

Description: Our Datacenter team will perform maintenance in our Netherlands Datacenter. Users on designated hardware may experience a brief service interruption while routine maintenance is performed. We will provide updates as they're made available.

As of 3:00 PM EDT :: This maintenance is now in progress.

UPDATE : This Maintenance has been completed.