[COMPLETED]az1-lr5 :: Unplanned Maintenance Wednesday 15th June 2022 04:34:48


Our System Operations team is performing unplanned maintenance on az1-lr5.supercp.com to ensure the stability of the server. Users hosted on this server may experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 8:50 AM EDT: Our System Operations team completed the maintenance and all services are back online at this time.