[RESOLVED] www66.a2hosting.com :: Service Interruption Wednesday 9th May 2018 12:03:13


www66.a2hosting.com is currently experiencing an interruption in service. Users will experience service degradation as a result.

UPDATE 16:15 EDT The server is back online and running normally.