[COMPLETED] Michigan Datacenter :: Network Maintenance Sunday 15th May 2022 20:13:08


Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption or slowness while routine maintenance is performed. We will provide updates as they're made available. 

UPDATE 03:20 AM EST: The maintenance has been completed. Please reach out to our support team should you encounter any issues.