[COMPLETED] Michigan Datacenter :: Network Maintenance Wednesday 11th May 2022 21:31:40


Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while the routine maintenance is performed. 

We will provide updates as they're made available. 

UPDATE 02:50 AM EDT: Customers with services connected to the Michigan network may experience slowness or short service interruption. Our Engineers are investigating the root cause of the issue. We appreciate your patience and we will keep you updated in this thread. 

UPDATE 03:25 AM EDT: The first stage of the maintenance is completed. Our Engineers are keeping an eye on all services' uptime and performance. If you are seeing issues please reach out to our support.

UPDATE 05:00 AM EDT: The next stage of the maintenance is initiated. We will keep this thread updated.

UPDATE 05:35 AM EDT: The maintenance is completed successfully. All services are up and running. If you notice any issues please contact our Live Support.