[RESOLVED] Michigan Datacenter :: Network Interruption Tuesday 10th May 2022 22:03:48


We are facing a network interruption in our Michigan Datacenter. Users hosted on some servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 2:15 AM EDT: Issues in our Michigan Datacenter have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.