[RESOLVED] Sectigo SSL :: Scheduled maintenance Saturday 7th May 2022 02:00:00


Start date: Saturday, May 7, 2022; 10:00 UTC 

Duration: Sectigo anticipates that its certificate-issuing platform will be unavailable during the maintenance. We will provide updates as soon as this maintenance is completed.

Please, feel free to check out Sectigo updates on their Status page:  https://sectigo.status.io/

UPDATE:: As of 12pm EDT :: Sectigo have completed this maintenance, if you are seeing any issues with certificate renewals please get in touch with support via ticket.