[RESOLVED] Ticket System :: Service Interruption Thursday 5th May 2022 00:19:55


Our Helpdesk/Ticket system is currently experiencing a service interruption. Clients may be unable to open new or update existing tickets. Our Engineers are investigating the root cause of this interruption. We will provide updates as more details are made available. Feel free to reach out to us via Live Chat or by phone during this time. We appreciate your understanding and patience!

UPDATE 05:30 AM EDT: Our Engineers are still working on the problem. Our support team will reply to your tickets as soon as it is technically possible. Please, feel free to reach out to our support in Live Chat or by phone in the meantime if you need an urgent assistance.

UPDATE 06:30 AM EDT: Issues with Helpdesk have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.