[COMPLETED] Live Chat :: Scheduled Maintenance Tuesday 10th May 2022 05:00:00


Start Date: Tuesday, May 10, 2022

End Date: Tuesday, May 10, 2022

Time: 9:00 PM - 10:00 PM EDT

Services Affected: Live Chat

Description: Our Live Chat Software requires mandatory maintenance to ensure smooth and stable service going forward. Our Live will be offline service while the routine scheduled maintenance is performed. Please use our ticket or phone system for assistance during this maintenance.

UPDATE 10:15PM EDT: Our Engineers are still working on this. We will post updates as more information becomes available. In the meanwhile, our remaining support channels (Helpdesk and Phones) continue to work normally. We appreciate your patience, cooperation and understanding in this regard.

UPDATE 10:35PM EDT: Maintnance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.