[RESOLVED] wwwsgss2.a2hosting.com :: Service Interruption Monday 7th May 2018 17:34:31


wwwsgss2.a2hosting.comĀ is currently experiencing an interruption in service. Users will experience service degradation as a result. Our admin team is aware and is working on the issue. We will post updates as they become available.

UPDATE 11:25PM EST: We are glad to report that sgss2 is back online and operating normally.