[RESOLVED]mi3-sr7 :: Service Interruption Thursday 21st April 2022 04:21:07


mi3-sr7.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 8:33 AM EDT: Our System Operations team resolved this matter and all services are online at this time.