[COMPLETED] Michigan Datacenter :: Network Maintenance Tuesday 19th April 2022 09:25:15


Start Date: Tuesday, April 19, 2022

End Date: Wednesday, April 20, 2022

Time: 10:00 PM EDT - 1:00 AM EDT

Description: Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post updates as they're made available.

UPDATE 10:00 PM EDT: Maintenance has been started as per schedule. We will post updates as more information becomes available in this regard. We sincerely appreciate your patience and understanding in this matter.

UPDATE 11:15 PM EDT: Maintenance has been completed. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.