[RESOLVED] Michigan Datacenter :: Network Maintenance Monday 18th April 2022 12:58:25


Start Date: Monday, April 18, 2022

End Date: Monday, April 19, 2022

Time: 11:00 PM EDT - 12:00 AM EDT

Description: Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread

UPDATE 11:45 PM EDT: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.