[COMPLETED]Michigan Datacenter :: Network Maintenance Friday 15th April 2022 07:01:36


Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while the maintenance is performed. We will update this thread with progress updates.

UPDATE :: 1:50 PM EDT: Our Network Engineering completed the maintenance in our Michigan datacenter.