[RESOLVED] mi3-mw2 :: Service Interruption Monday 11th April 2022 01:09:05


Server mi3-mw2 is currently experiencing a service interruption. Users hosted on this server will experience web service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update: 05:32am EST: Our System Operations team resolved this matter and all services are back online at this time.  If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.