[RESOLVED] Sectigo SSL Certificates :: Degraded Performance Sunday 10th April 2022 02:01:52


Sectigo is currently experiencing degraded performance with its issuing platforms. Users will experience delays with free SSL certificates being issued or renewed as a result.

You can view Sectigo's status page here:

 https://sectigo.status.io 

We will provide further updates as they're made available.

Update: April 10, 2022 6:56PM UTC: Sectigo confirms that the issue has been resolved successfully.