[RESOLVED] MI3-SS55 :: Service Interruption Sunday 3rd April 2022 09:01:07


mi3-ss55.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 1:04 PM EST: Our System Operations team resolved this matter and all services are back online at this time.