[RESOLVED]Multiple Servers :: Outbound Email Interruption Thursday 31st March 2022 05:15:22


We are aware of multiple reports of intermittent issues with outbound email affecting shared & reseller platforms in our Michigan datacenter. Our System Engineers are further investigating this matter. We will continue to provide updates as they're made available.

UPDATE 9:55 AM EST: Our System Engineering team resolved this matter. Please contact our Guru team directly if you continue to experience outstanding outbound email issues.