[RESOLVED] Michigan Datacenter :: Network Interruption Wednesday 23rd March 2022 18:31:20


We are facing a network interruption in our Michigan Datacenter. Users hosted on some servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:05 PM EDT: Issues in our Michigan Datacenter have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.