[RESOLVED]Phone System Interruption Wednesday 23rd March 2022 08:44:36


Our phone system is currently experiencing a service interruption. Please use our Live Chat or open a support ticket for further assistance. We will provide updates as more details are made available.

UPDATE 2:00 PM EST: Our System Operations team is still working on this matter. We will continue to provide updates as they're made available.

UPDATE 2:20 PM EST: Our System Operations team confirmed our phone system is back up and running. We're available again at this time for phone calls. We're still working on fully stabilizing the phone system. We will continue to provide updates as they're made available.

UPDATE 3:45 PM EST: Our System Operations team confirmed the phone system is fully stable at this time.