[RESOLVED] Arizona DC :: Intermittent Interruption (MX) Tuesday 22nd March 2022 14:07:41


We are aware that some of our clients located in Mexico are facing intermittent issues reaching sites hosted in our Arizona Data Center. Our Network Engineers are investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:30PM EDT: Our Engineers are still working on it. We will post updates as more information becomes available. We sincerely appreciate your patience and understanding in the meanwhile.

UPDATE 1:10AM EDT: Network issues have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.