[COMPLETED] Michigan Datacenter :: Scheduled Maintenance Tuesday 22nd March 2022 20:00:00


Start Date: Thursday, March 23rd, 2022

End Date: Thursday, March 23th, 2022

Time: 12:00 AM - 03:00 AM EDT

Description: Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread

UPDATE 12:00AM: Our Network Engineers have started the maintenance as per schedule. We will post updates as more information becomes available.

UPDATE 03:00AM: The maintenance was completed as per schedule.