[COMPLETED] ssr21 :: Scheduled Maintenance Wednesday 23rd March 2022 20:00:00


Start Date: Thursday, March 24, 2022

End Date: Thursday, March 24, 2022

Time: 2:00 AM - 6:00 AM EDT

Description: Our System Operations team will be performing scheduled maintenance on ssr21.supercp.com. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE: 02:50 AM: The maintenance is completed successfully, the server is up and running. Please reach out to support should you encounter any issues.