[COMPLETED] Amsterdam Datacenter :: Scheduled Maintenance Thursday 17th March 2022 09:32:53


Start Date: Thursday, March 17 (EDT/Amsterdam)

End Date: Thursday, March 17 (EDT), Friday, March 18, 2022 (Amsterdam)

Time: 6:00 PM - 9:00 PM EDT (11:00 AM - 2:00 AM Amsterdam)

Description: Our Network Engineering team is performing network maintenance in our Amsterdam Datacenter. Users may experience a brief service interruption while the routine maintenance is performed. We will provide updates as they're made available.

UPDATE 6:00PM EDT: The maintenance has been started as per schedule. We will post updates as more information becomes available.

UPDATE 6:50PM EDT: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.