[RESOLVED] Singapore Network :: Connectivity Issue Wednesday 16th March 2022 22:17:11


Our Singapore data center is currently experiencing a service interruption. Users may experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. We sincerely appreciate your patience and understanding in the meanwhile.

Update: 3:15 AM ET: Our System Operations team resolved this matter and all services are back online at this time.