[RESOLVED] Ticket System :: Service Interruption Tuesday 15th March 2022 16:14:22


Our Helpdesk/Ticket system is currently experiencing a service interruption. Clients may be unable to open new or update existing tickets. Our Engineers are investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 8:30PM EDT: Issues with Helpdesk have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.