[COMPLETED] Michigan Datacenter :: Scheduled Maintenance Wednesday 16th March 2022 21:00:00


Start Date: Thursday, March 17th, 2022

End Date: Thursday, March 17th, 2022

Time: 12:00 AM - 03:00 AM EDT

Description: Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will provide updates as they're made available.

UPDATE 12:00AM EDT: Our Network Engineers have started the maintenance. We will update this thread as more information becomes available.

UPDATE 3:40 AM EDT: The maintenance has been completed at this time.