Arizona Datacenter :: Scheduled Maintenance Tuesday 15th February 2022 05:40:09


Start Date: Wednesday, February 16, 2022

End Date: Thursday, February 17, 2022

Time: 9:00 PM - 12:00 AM EST (7:00 PM - 10:00 PM MST)

Description: Our Network Engineering team is performing network maintenance in our Arizona Datacenter. Users may experience a brief service interruption while the routine maintenance is performed. We will provide updates as they're made available.

UPDATE 9:00PM EST The scheduled maintenance has begun at this time. We will provide updates as they become available.

Update 11:00PM EST The scheduled maintenance has been completed at this time.