[RESOLVED]Sectigo SSL Certificates :: Degraded Performance Monday 31st January 2022 22:28:16


Sectigo is currently experiencing degraded performance with its issuing platforms. Users will experience delays with free SSL certificates being issued or renewed as a result. You can view Sectigo's status page at https://sectigo.status.io We will provide further updates as they're made available.

UPDATE 5:05 AM EST: Sectigo is still experiencing a short-term backlog with its certificate issuance. You may experience delayed issuance until all the backlog has been cleared. We will update you accordingly.

UPDATE 1:15 PM EST: Sectigo is still experiencing issues with its certificate issuance. You may experience delayed issuance until all the backlog has been cleared. We will update you accordingly.

UPDATE 3:22 PM EST: Sectigo fully resolved all issues and all certificates should be issuing as expected at this time.