[COMPLETED] NL Datacenter :: Network Maintenance Tuesday 25th January 2022 13:04:03


Description: Our Network Engineering team is performing network maintenance in our Amsterdam Datacenter. Users may experience a brief service interruption while the routine maintenance is performed. We will update this thread with progress updates. We sincerely appreciate your patience and understanding in the meanwhile.

UPDATE 11:00 PM EST (5:00 AM Amsterdam): Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.