[RESOLVED] Intermittent Domain Registration Issues Thursday 16th December 2021 10:52:43


Our System Engineers and Development teams are investigating reports of issues with the domain registration tool on our website. Some domains are being reported as unavailable. We will provide more updates as they're made available.

UPDATE 4:40PM EST: Issues related to domain registration have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.