[RESOLVED] MI3-LR3 :: Service Interruption Tuesday 23rd November 2021 06:05:36


MI3-LR3 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:24 APM EST: Issues on mi3-lr3 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.