[RESOLVED] European Data Center Network Connectivity Wednesday 17th November 2021 01:40:00


Our European data centre's network is currently experiencing intermittent service interruptions. Our Engineers have identified a cause of these issues and are actively working to correct the interruptions. Further updates will be provided as we have more information.

UPDATE As of 14:00 EST:: Our engineering team is still working on this issue and we will update you as we know more.  Please reach out to us if you see any part of your site not working via LiveChat or Ticket.

UPDATE As of 15:55 EST:: Our engineering team has resolved this issue now and if you still see issues with your site please reach out via LiveChat or in a ticket.  We're still monitoring the situation.

UPDATE 19:00 EST: Our team is aware of network interruption faced by some of our clients. Our Network Engineers are working on this. We will provide updates as more information is available in this regard. We sincerely apologize for the inconvenience faced in the meanwhile and appreciate your continued patience and understanding in this matter.

UPDATE 04:00 AM EST, November 18th: We are still receiving some reports of slowness or intermittent connectivity troubles. Our Engineers are continuing to work towards a resolution.

UPDATE 05:30 AM EST, November 18th: We are aware of network interruptions faced by some of our clients. Our Network Engineers are working on this. We will provide updates as more information is available in this regard. We sincerely apologize for the inconvenience faced in the meanwhile and appreciate your continued patience and understanding in this matter.

UPDATE 06:45 AM EST, November 18th: Our System Operations team is still working on the issue, and you may experience slow performance during this time. Additional updates will be provided as they become available. We appreciate your ongoing patience and understanding.

UPDATE 8:20 AM EST, November 18th: Our Network Engineers are aware of reports of network interruption faced by some of our clients. Our Network Engineers are working on this. We will continue to provide updates as more information is available.

UPDATE 10:45 AM EST, November 18th: Our Network Engineers are working hard to stabilize the performance and connectivity. We appreciate your ongoing patience and understanding.

UPDATE 12:13 PM EST, November 18th: Our Network Engineers stabilized the performance and connectivity at this time. We will continue to monitor this situation closely. Please contact our Support team directly if you continue to experience any outstanding issues.

UPDATE: Issues associated with this incident have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.