Sectigo is currently experiencing degraded performance with its issuing platforms. Users will experience delays with free SSL certificates being issued or renewed as a result. You can view Sectigo's status page at https://sectigo.status.io. We will provide further updates as they're made available.
UPDATE 6:50 AM EST: Sectigo is still experiencing a short-term backlog with its certificate issuance. You may experience delayed issuance until all the backlog has been cleared. We will update you accordingly.
UPDATE 08:29 AM EST: Sectigo is still working on this backlog and unfortunately they have not given an ETA for this to be resolved, we'll update you as we know more.
UPDATE 11:19 AM EST: Sectigo is still working on this backlog and unfortunately this means SSL generation will be slower than normal. If you have any difficulties then please reach out to our team and we'll work with you to resolve this.