Intermittent Connectivity Issues Sunday 14th November 2021 00:02:53


Our System Operations team is currently aware of reports of intermittent services connectivity issues affecting a subset of customers in our Netherlands data center. We are working on this and will provide updates as more details are made available. We sincerely apologize for the inconvenience and appreciate your patience and understanding in this matter.

UPDATE 07:25 AM EDT: We are still receiving some reports of slowness or intermittent connectivity troubles. Our Engineers are continuing to work towards a resolution.

UPDATE 15-Nov, 01:15 AM EST: Our System Operations team is monitoring the situation in the Netherlands facility closely for stability. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.