[RESOLVED]VPS & Dedicated servers :: DNS Interruption Thursday 11th November 2021 21:56:57


Some VPS and Dedicated servers are currently experiencing a DNS service interruption. Users hosted on the impacted servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 3:51AM EST: Our System Operations team is still working on the issue, and you may experience slow performance during this time. Additional updates will be provided as they become available. We appreciate your ongoing patience and understanding.

UPDATE 4:52AM EST: Issues with DNS have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.