[RESOLVED]Sectigo SSL Certificates :: Degraded Performance Wednesday 10th November 2021 21:51:54


Sectigo is currently experiencing degraded performance with their issuing platforms. Users will experience delays with free SSL certificates being issued or renewed as a result. You can view Sectigo's status page at https://sectigo.status.io. We will provide further updates as they're made available.

UPDATE 6:53 AM EST: Sectigo is still experiencing a short-term backlog with its certificate issuance. You may experience delayed issuance until all the backlog has been cleared. We will update you accordingly.

UPATE 2:45 PM EST: Sectigo is now operating as expected. If you continue to experience issues please contact our Technical Support team directly.