[RESOLVED]Sectigo SSL Certificates :: Degraded Performance Tuesday 9th November 2021 08:38:37


Sectigo is currently experiencing degraded performance with their issuing platforms. Users may experience issues with free SSL certificates being issued or renewed as a result. Sectigo & cPanel are working with their developers on this matter. We will provide further updates as they're made available from the vendor.

UPDATE 2:01 PM EST: Sectigo & cPanel have resolved this issue and certificates are now issuing as expected at this time.