[RESOLVED] Support System :: Service Interruption Tuesday 26th October 2021 18:57:10


Our support system is currently experiencing a service interruption. Some User responses are not posting to tickets. Our development team is investigating the root cause of this. In the meanwhile, we would request you to reach out to our live support and should it require a ticket, have them create or update a ticket for you. We will provide updates as more details are made available.

UPDATE 11:25PM EDT: Issues with help desk have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.