[COMPLETED] Michigan Network Maintenance Wednesday 27th October 2021 20:00:00


Start Date: Thursday, October 28th, 2021

End Date: Thursday, October 28th, 2021

Start Time: 12:00 AM EST

Services Affected:

Michigan Data Center

Description: Our Network Engineering team will be performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while the routine maintenance is performed.

UPDATE 12:05AM EDT: Maintenance will begin shortly, further updates will be provided as the maintenance continues.

UPDATE 12:15AM EDT: Our team has started the maintenance. We will update this thread as the maintenance progresses. Thank you for your patience.

UPDATE 01:15AM EDT: Our System Operations team completed the maintenance and all services are back online at this time.