[Resolved] Sectigo SSL Certificates :: Degraded Performance Monday 25th October 2021 02:30:25


Sectigo is currently experiencing degraded performance with their issuing platforms. Users will experience delays with free SSL certificates being issued or renewed as a result. You can view Sectigo's status page at https://sectigo.status.io. We will provide further updates as they're made available.

 

UPDATE: Resolved, Sectigo corrected the issue with the performance on their platform.