[RESOLVED] mi3-sr11 :: Service Interruption Saturday 23rd October 2021 18:23:55


mi3-sr11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:55 PM EST: Our System Operations team has resolved this matter and all services are online at this time. Please reach out to our support team should you encounter any further issues.