Netherlands Network :: Scheduled Maintenance Tuesday 12th October 2021 06:27:11


Server Time: Wednesday, October 14th, 2021 - 00:00 AM - 04:00AM (GMT+2)

EDT Time: Tuesday, October 13th, 2021 - 6:00 PM - 10:00 PM

Services Affected:

Netherlands Network

Description: Our System Operations team will be performing scheduled maintenance and upgrades in the Netherlands Network. Users may experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 6:21 PM The scheduled maintenance has begun.

UPDATE 10:00 PM The scheduled maintenance has been completed. Please reach out to our support team should you encounter any issues.