[RESOLVED]Michigan VPS Platform :: Degraded Performance Tuesday 5th October 2021 10:21:52


Our System Operations team is investigating reports of degraded performance affecting a small subset of customers hosted on our VPS platform in our Michigan facility. Users hosted on affected servers will experience service degradation as a result. Our System Operations team is investigating the root cause of degraded performance. We will provide updates as more details are made available.

UPDATE 2:54 PM EST: Our System Operations team has resolved this matter and all services should be performing as expected at this time. We will continue to monitor this situation closely.