[RESOLVED] Phone System Interruption Monday 4th October 2021 01:39:16


Our phone system is currently experiencing a service interruption. Please use our Live Chat or open a ticket while our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

 

UPDATE 06:24AM EDT: Our Engineering team has resolved this matter and our phone service is available again at this time.