[RESOLVED] Netherlands DC :: Service Interruption Tuesday 28th September 2021 13:40:27


Our Netherlands data center is currently experiencing a service interruption. Some users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:00PM EDT: All issues have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.